Partial service disruption

Incident Report for Personio Statuspage

Resolved

This incident has been resolved.
Posted Jan 19, 2026 - 14:39 CET

Identified

We are currently experiencing some issues with requesting eSignatures. The affected actions are:
- requesting signatures
- signing a document in Personio
- downloading audit trail

Please be aware that the remaining system is stable and running according to expectations. Our engineering teams are already working on a solution.

We will keep you posted with the latest information on this page and apologize for the inconveniences.
Posted Jan 19, 2026 - 11:10 CET
This incident affected: Overall System availability and Core Platform (Documents & E-Signatures).