Resolved
The implemented fix is working as expected and the issue is fully resolved. We apologize for any inconvenience this may have caused. Thanks for your understanding!
Posted May 07, 2026 - 13:08 CEST
Monitoring
A fix has been implemented. Our engineers are monitoring the systems to ensure the issues is fully resolved.
Posted May 07, 2026 - 11:48 CEST
Investigating
Our system is currently not available due to a global service outage. Engineers are already working to get everything up and running again.
We will keep you posted with the latest information and apologize for any inconvenience this may cause.
Posted May 07, 2026 - 11:36 CEST
This incident affected: Overall System availability, Core Platform (Public API, Support & Help, Analytics, Company Configuration, Documents & E-Signatures, Employee & Organization Management, Home & Inbox, Personio built Integrations & Marketplace, Login & Authentication, Mobile App, Salary Management, Time Management (Time Tracking, Time-off, Overtime), Workflows & Automations), Apps (Conversations, Compensation Management, Performance & Development, Recruiting, Surveys, Whistleblowing, Employer of Record (powered by Remote.com)), and Payroll (Personio Payroll DE, Preliminary Payroll (and file export integrations), Datev Integration, Xero Integration, A3 Integration, Loket Integration, Tax Advisor Platform).