Partial service disruption

Incident Report for Personio Statuspage

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 17:37 CEST

Monitoring

We are currently experiencing some issues across multiple areas/modules. The following modules are affected:
- Analytics
- Performance & Development
- Time Management
- Workflows & Automations

Our engineering teams are already working on a solution.

We will keep you posted with the latest information on this page and apologize for the inconveniences.
Posted Jun 18, 2026 - 12:53 CEST
This incident affected: Overall System availability, Core Platform (Analytics, Time Management (Time Tracking, Time-off, Overtime), Workflows & Automations), and Apps (Performance & Development).