Personio Developer Hub unavailable

Incident Report for Personio Statuspage

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 09:18 CET

Identified

We've encountered a technical limitation during recent infrastructure changes for the developer hub. All services are expected to return to normal by the end of our routine maintenance window.
Posted Feb 24, 2026 - 13:00 CET

Investigating

We are currently investigating a technical issue in the Personio Developer Hub. Public API documentation is temporarily offline.

We will keep you posted with the latest information on this page and apologize for the inconveniences.
Posted Feb 20, 2026 - 17:52 CET