The implemented fix is working as expected and the issue is fully resolved. We apologize for any inconvenience this may have caused. Thanks for your understanding!
Posted May 19, 2026 - 14:26 CEST
Monitoring
A fix has been implemented. Our engineers are monitoring the systems to ensure the issues is fully resolved.
Posted May 19, 2026 - 12:19 CEST
Update
Deleting employees might also not be possible. We are continuing to work on a fix.
Posted May 19, 2026 - 10:33 CEST
Identified
The issue has been identified. Salary-related product areas, like the employee profile salary tab or salary reports might also not load. A fix is being currently implemented.
Posted May 19, 2026 - 10:17 CEST
Investigating
We are currently experiencing some issues with the payroll module. The following features are affected: - Approvals might be blocked - The Payroll module might not load
Please be aware that the remaining system is stable and running according to expectations. Our engineering teams are already working on a solution.
We will keep you posted with the latest information on this page and apologize for the inconveniences.
Posted May 19, 2026 - 10:03 CEST
This incident affected: Overall System availability, Payroll (Personio Payroll DE, Preliminary Payroll (and file export integrations), Datev Integration, Xero Integration, A3 Integration, Loket Integration, Tax Advisor Platform), and Core Platform (Employee & Organization Management, Salary Management).