Partial service disruption in Personio Payroll DE
Incident Report for
Personio Statuspage
Resolved
This incident has been resolved.
Posted
Sep
05
,
2025
-
10:12
CEST
Update
We are continuing to investigate this issue.
Posted
Sep
05
,
2025
-
10:12
CEST
Investigating
We identified an issue and Payroll DE Approvals have been deactivated. There may also be lag on the Payroll related pages.
Please be aware that the remaining system is stable and running according to expectations. Our engineering teams are already working on a solution.
We will keep you posted with the latest information on this page and apologize for the inconveniences.
Posted
Sep
04
,
2025
-
12:57
CEST
This incident affected: Personio Payroll DE.
×
Subscribe to Incident
Subscribe to updates for
Partial service disruption in Personio Payroll DE
via . You'll receive .