Resolved
This incident has been resolved.
Posted Dec 02, 2025 - 12:30 CET
Update
We are continuing to monitor for any further issues.
Posted Dec 02, 2025 - 12:23 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 02, 2025 - 12:21 CET
Update
We managed to mitigate the majority of the issue, however, there is still degraded performance in our Time Management product area.
Posted Dec 02, 2025 - 12:05 CET
Identified
We are currently experiencing a global service outage. Personio may not be accessible or loading very slowly.
However, the issue has already been identified and a fix is currently being implemented.
Posted Dec 02, 2025 - 10:51 CET
This incident affected: Overall System availability, Core Platform (Public API, Support & Help, Analytics, Company Configuration, Documents & E-Signatures, Employee & Organization Management, Home & Inbox, Personio built Integrations & Marketplace, Login & Authentication, Mobile App, Salary Management, Time Management (Time Tracking, Time-off, Overtime), Workflows & Automations), Apps (Conversations, Compensation Management, Performance & Development, Recruiting, Surveys, Whistleblowing, Employer of Record (powered by Remote.com)), and Payroll (Personio Payroll DE, Preliminary Payroll (and file export integrations), Datev Integration, Xero Integration, A3 Integration, Loket Integration, Tax Advisor Platform).