Global service outage

Incident Report for Personio SE & Co. KG

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 12:42 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2025 - 11:44 CEST

Investigating

Our system may currently be not available due to a global service outage. Engineers are already working to get everything up and running again.

We will keep you posted with the latest information and apologize for any inconvenience this may cause.
Posted Apr 01, 2025 - 11:27 CEST
This incident affected: System availability.